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A LIRS S7-HiGraph V5.3 BL bR A S #.

= Conditions | TH#500ms
L T

E Transition actions
Delay time 5.3

K 4-17: ZEIRH 8] ZmfE

4.5, BEB iR
4.5.1. S7-HiGraph 1 R4 X K HFRIEERN:

e Auto mode BEFEAPIRZS H RS EINSE AutomaticMode 9 1 BAfIA
e Manual mode HEAREUHPIRZS HH R G ERA 2% ManualMode A1 EfA



4.5.2. 3t T B FAFVIBEIR A .

1. WUR—ANFEHR & Auto JEME, A4 TR DL I U T #6460
o M4 (transition condition) i
0 AutomaticMode i A 1
2. WR—AEAREA Manual JEME, LA JAE DR DU T e 4
o M4 (transition condition) i
0 ManualMode ¥fti y 1
3. WR—AEHA L Manual 5L Auto JEMVE, WAL SO #6460 2% A1 R vk & T idh AT i e
4.6. BIERHAmE

4.6.1. BRAH.:

B EIRAINA —EHEAIREE , XERZSEAT Aged B,  IRAFATR 2o
Thhg: RSB DR PLES B M MSL T, N TR A BRSO &, TR E AR
FPRESRIEERA P H A K,

4.6.2. BIRHARESE:

LR ERERA . At AT IER Sources H3t, Insert New Object->Graph group, i\
k44

APR 2. WEHSEH Insert->Instance, XA LUESE AT H b O 4% 'S 56 R HPIRES K. f H T
PAZ A — ARSI, W R RS Molding 78 EIR A A E N TS SN 1 3 1R

Molding_1

Molding
1 \

felfching_ 1 /Robot_felching

Molding_2 [ Robot_1

ﬂ,&jfd}ﬂg e prociuct OF Aproduct ok 22— el Robot

3 7 2

prociuct OF A product o 3

Molding_3 | o —

Molding

4

K 4-18: IREEMENH YA



AUR 3. LFESEH Edit->Run Sequence, AT LU b i Sk R BE 2SR EIHE IR A I AT I
F?
DY 4 PSHL AERRAS, BFE-AER, AEEINEKNE DTS T EL

Molding_1
Molding

X||Graph group(1] - book-higraph%5 7 Program(1t... [Malding 1]

4
Mame |Data T_I,Ipe| Current parameter |Hessage | | AN e
Autormatichode BOOL i2.0 L ——
Manualtode BOOL
Il zrhd=gQuit BOOL
ternp_of_product  Beal "EHIE " ternp_of_product]
inject_rnaterial Boal q3.0
extruzion Bool q3.3
cooling Bool Q3.6
deliver_product Bool q4.1 W S Fr oK )
Robot_fetching B ool i 4! R 2 U
product_OF, B ool Robot_1.product_ok_1 out

K 4-19: WIREEE RS HCSHE

4.7. REEHBRZHgmE
47.1. HEHERER

€ THE (Message) HIRAERSE 2 HAKERE , —MREERE 55— MRS E R D2
5T, XFEAEIZATRS, IRZSEZ (AW DL H AR .
HEZ: WHE (Message) 7] LL2y NP
1. Internal message: 7£—MEIFRMATMZAREEZEBATESG, HiEFHET S7T-HiGraph
Htm e A bR T R RBEER T AT bit .
2. External message: AN EIFRA 2 (B84 S7T-HiGraph 5 & STEP7 F2/% Z [Midf5 . 1XFh
WS A AL, ZmFRE AT E Lo



Molding_1

Molding Message #7 & AR AET LG
%~ Message

fetching 1 /Robot felching /
Molding_2 % Robot_1

ﬂ#?ofdjng - prociuct OK /product ok _2— “peel  Robot

3 7 2

prociuet O Aprodiet ok 3

Molding_3 | —

Molding

4

K 4-20: IREEZ AW B Ex
4.7.2. FHHERZE

JIE B out AR BLGHUE B RS O RSB R in R
WEEA -——-0UT HELE -5 B-——-INTH B E----> REE B
A& SUP IR

FTFF % T B R A

£ IN_OUT AZ& 3R r5E X —> BOOL AL &

TEVH BRIk $ < “out™”

FTHF A BRSO R AIR S

£ IN_OUT AZ&E 3R g X —> BOOL AL &

FEVH BRI $E“<in~~

H: PR E R AR 2 A4 R AT DA )

4.7.3. EEHEE

o o AW DN P

TR N TERHEARR, HIAEIETEERE LROH B RPRES R DE 507, BE R ER AT
HERANEEE Internal message
1. P FRERIREEME S CREED
2. fE<“Current parameters” {1, EFRIEH B S
3. WA REALIR, KA BBCRESEIAR. Sk &4 . 1. Robot_1.product_ok_1,
Z WK
4. XTHERR, AFEFXRAS, FHALREEXREREEERAS T CRHASTE.



Molding_1

Molding
1

LI -

|Graph group(1] -- book-higraph’5 7 Program(1]5... [Molding 1]

4

= Hame |Data Type|l:urrent paramelter |Hessage
Automatictode BOOL 13.0
tanualtdode BOOL
I zrbd zald it BOOL
temp_of_product  Real "{EALE " temp_of_product]
inject_rnaternial Boaol a0
extruzion Boaol 033 HARIEN A
cooling Boaol qi6
deliver_product B ool q4.1
Robot_fetching Bool
product_OFK, Bool Raobot_1. product_ok_1

Kl 4-21: ERH B R
RN External message:
1. EPFEREHENE S CREED
2. fE<“Current parameters”” i, EFRLENEZE
3. MANIECEEAFR, Wi: DB10.DBX5.1, AR 5EEE

4.8. BFHmiF
4.8.1. GRiFiEIR

ERRTFRECEE, AP RERmEEG, A0 DL AT RS KBS . g Bk b 1 i B X R G
BATERAEIRE HETW, AP —E 2 TR EN.

WEPESE . Options -> Settings for graph groups/state graphs -> Compile, 7740 T B H
JA S



Graph Group Settings 'Graph’ i i 5[

Fonts I Graphicsl Save Format  Compile |Diagnu:use|

FC: |30 #1 N\ HiGraph

5o [0 ~ "R FC,DB
[¥ Restructure data block

[T Generate reference data B T B %
kemon reserves [waordz] in data block; Iﬁ Hjni e

— Only for ingtances without their awn caresponding settings;
[T Switch Any ransitions once only
[™ Erecute cyclic actions with RLO=0

[ Include preceding cyclic actions in entry cycle

Cancel Help

K 4-22: YmiFikIiw E

4.8.2. Memory reserve (words) in data block:

TRE FEHUR S A ABIDIRES, W, FP E E SRS AR R A BAE LB ST 3
PP, M EREE.

VEE. MIETNAE Restructure data block EIHEIERERT, 4B K.

WA AAEESR AT

£~ state graph 12 words

&1 message 1 bit

fE STAT Ao s&rh )AL &

$4fm27: BOOLEAN 1 bit

AL Word/ INT/DATE/SSTIME 2 bytes

25 AL: Dword/DINT/REAL/TIME/TOD 4 bytes

4.8.3. BIRHAKRE

R TR E MR LN A R

KIRAT 5 KRS EESREAEREHEFRRE, X TREREEE S, KA ERAS
WHE.

Switch Any transitions only once

TG, L6 RFE LA Any transition FRFEIFPIRASFE, U Any transition AFE R4



P,
Cyclic actions with RLO 0

WIS, RSB IR, RS0 RLO i 0, FFFEXRIAT—IX cyclic actions FHIIE4.

REFT LU THRERSE T IrA B 1 KIS S 0. (AR WL b PR4E AR 2D
Preceding cyclic actions also in the entry cycle

WIS, EHENFIN, (C-) T HRHR AT IR (LN BRAE T WL 1] b PR )
4.9. BRFRH/ T/

49.1. BFHEH

S7-HiGraph "4 FC, DB, mILATEREREFEA, #l: 0Bl.
CALL FC 31 // ] S7-HiGraph H4=H FC
INIT_SD:=M100.1 1P (A aG A A2 il

492 BFTH

PR P T REALHE 0T 7 -
e S7-HiGraph FC

e S7-HiGraph DB

e S7-HiGraph ¥ DB

« (0B, FB or FC)

- B HEME AR ER

IR FE T2 TIRE, T REEEAE AN T ER )

« HiGraphErrEmitterFB (FB20), k&i\#EHLiLl

« HiGraphMsgEmitterFC (FC101), #% =42 W

= HiGraphUnivEmitterFC (FC102), Frutizir

e Alarm_S (SFC18) and Alarm_SQ (SFC 17), FruEiZl
Heix 2e7E Block ST HER N 303 PLC

4.9.3. BFAR

U

f£ S7-HiGraph F2fy T #5EE, JFHYPORME, ATRAEERIRAMUE T, EHEH Debug ->

Monitor RIEHLAEF MIPATHOL. ] DR BRI SRS B, IEEOIRES B RS



Permanent Instructions

C-
AINIT_SD; | - c

Movement Up
C|= Up;

Bottom

C |= OM_Bottom;

K 4-23: IEEMA
RLO: #HizfT 45 R
STA: RAAL
STD: ACCUL H iy %
FERRA/REERIME T, 75329 Debug -> Select variable, 7] LA FI O 1028 Bk 47

Wit

5. S7-HiGraph M F B TE

51. BN ITETZEX

1-3 SRS B SR G N s, LT R BUE, JFRE AL IA
F.



AL 1

AL 2

AL
ik

&AL 3

;

PRI T ZiRE

LT T Z0ife:

A 4

A 4

ik

K 5-1: 7 2 R GER K

< vt >

v
TN R

v

Frlk

v

e

v

A

v

TR RIS

(VA

K 5-2: WAL L ZHFE




< vt >

y

HAAL 1 OK

oA

BahZE AL 1

v
ENNE

v
BT B AREA

Y

HAHL 2 OK

iy

B E AL 2

v
ETAF

v
& A B AREA

y

HAHL 3 OK

AN
=]

=]
e

B8l 2 AL 3
B} Vi BRARHIREL OK 18 7E
=L RIERL B AR T A

v
& TS

Kl 5-3: HUIT L ZHiE
5.2. S7-HiGraph f&j 8=
HERHEIE T, KgE —A ST-HiGraph F TR T 256 R -
<> BEHIREAS AL
<> EHIPUR T
<> WAL AU T A

1) 485 Sources -> Insert New Object-> State graph, %7~ molding
2) A Sources -> Insert New Object-> State graph, %5 A robot
3) Ai#d i Sources -> Insert New Object-> Graph group

4) Xt molding FT7F, 4w BNLFE T, & UMASE



B S|E| S| & =@ oo elda] 50| <N

Contents OF: ‘Environment Interface) IH'

El--% Environmer |Hame Data Type |Cumment

= Interfa [@ Automatichiode
-0 I = Manuslibode
------ = @ Usrhsguit

Automatic mode
Manual mode
Meszzage acknowledgement

- El[temp_nfjrngﬂud Real

..... = e

[
[

(-4l 5T#
[+-{Zx] Blocks

45 Symbal:
- fill Librarie

L [

5) gmi AL S 5

H 3

TR

K 5-4: B ASEL

2% =|d| 8| 4R o] e]d] &

Conkents OF: 'EnvironmentiInterfaceloUT!

El--% Environmer
L——_I@ Interfa
-0 IN

SEn Yo'l
[0k TH_
[+ 5TF

6) ZidE MBI B

[Hame Data Type  [Comment

‘B |inject_material  |Bool

B extrusion

= coaling ~
= deliver J:urn:udu?t\
j |

KA R

K 5-5: A LA 1 2 5L



Hl%E 2E| & &R o~ enld| ] 1<

| &g

Contents OF: ‘EnviranmentiInkerface IN_OUT

El--% Ervviranmient
EI@ Interface
-4 M
-4k OUT

=) 40k IN_OUT

-2 Robat_is_OF
: i‘EI produck Ok,
=-qm STAT

[#-{z3] Blacks

[-a3] Symbals

EEI---‘ Libraries

7) HEAENESEES

|Hame Data Type

|Message Type [Comment

r*El Fobot_i=_ Ok |Bool

Biool

= product_ Ok
p=|

PR, THE
KA, 1%
HEE U T

5-6: ZiiHR AL R

i
out

BB T At
2, WRE
LEVSLEIPN

55|38 @|W| S| #(8|B| oo enlda| o] <]

8) WNIIARZS Kokt

|Contents OF: 'EnvironmenttInterfacel STAT'
= £ Ervironment & [Hame Data Type  [Comment
[=I @ Interface ‘W ST_Currvalue  |DWVYORD Remaining supervis
[+ 2 IN W IMT_SD Boal Start parameter for
[+ OUT g CurrentState  [Wardl Current state
A2 IN_OUT | PreviousState | Uyord Previouz ztate
C [ STAT = StateChangs  |Bool State tranzition
B W,
L WTLT
i HUBE TR
1N J

5-7: AN SEESH



RewEH AR R IR LS
o

I 7 |AINIT_SD,;

rinject_material;
r exrusion,
rcaoling,
tdeliver_product
rrobot_fetching,
t product ok

? ]A Autornatichode; ]

FIAR AR H

L

TR ]

K 5-8: IIILIRAS S & A

9) XUdriRA, Wina-AiE 4

A% SH| 8| 4R oo eldl o] <>

rextrusion;
rcoaling;
rdeliver_product;
r robot_fetching;
tproduct_ok;

rproduct ok

E g inject_matedal;

A ) e 1
1% wait time

H | rinject_materal; |,
WT | 825

t_fetching, |

| termp_1;
H
| Molding - example_language’s 7 Frogram(5)h... [State 1]
4
=l Inztruction Type [nztructions
= Entry Actions | |r product_OF,; ﬂ
b E [1] % inject_raterial;
=l Preceding Cyclic Actions
[ Cuclic Actions
= Exit Actions fe Ak STL, v
M %] j;‘bT“”’
WalTime o AR =

B 5-9: W& RS FHITES

10) AAHLREFPHE Y



| | ¢ product_ok; |

1 | 7 |A AutomaticMode;

LR LT T % ¢ product Ok
I Rl E | sinject_mate fal
olmm_fetﬁhmg; 1 """"" H | rinject_materal;
'mmmﬁﬁj; wqma

A
HEANLFD
E |5 ewrusion |.--- 2
* | R extrusion;
WT | T#18
P FIE 18
G TR S
6T 90 i W]z
s deliver_product "\EFWF'_DLF'VDUU ct;
T 900
rdeliver_product; < '
ANRECE [t cooiing,
¢ -
K 3

K] 5-10: RAHLFE A v

11) WU RE P



rmave_to_linet, P
r move_to_line2; -
r move_to_lined; (-
r product_ok_1;
E |r fetching_1;
r product_ok_2
r fetching_2;
r product_ok_3,
r fetching_3;

__--|? |aauh:uma1j|:rmde; |

H B

£ = fetchifin, 1 SR )
= move_to_lite\ 15BN T

r fetching_1; ‘@jﬂ%

r move_ta_linet,
wr [T#10s N
HU 1 5 b

f, HEEIRE

W J

= fetching_2;
z move_to_line2,

r fetching_2;
r mu:we_tu:u_hne_?f;,,a
WT | T#10s

X

. _| 7 | o product_ol_3;

= fetching_3;

E = move_to_lined;

- r fetching_3;
X P
r mowve_to_lines;

w1 | T#10s

E 5-11: TR

12) Wi Graph group (1) #T7F, #i## Insert instance, 713 H #1#) molding Fil robot
13) AT LIAT B A Run Sequence

14) ¥ molding il JR5IG 2 ¥k

15) %&#% molding, 73 it 24k



5% S|H| 2| &= o] eud| e <[>

—— &
Molding 1

Wodciing
P —

feriing 1/ R obot Ehing

Molding_2 \\-\._ Robot 1
Wodding VT O OO L0 el Do}

3 e 2

prockc OM/ prockict o R

Mol ding 3 “__/—*f;—

elinE [ B A2 9 L
A
Z||Graph group(1] -- example_languages 7 Program(5)h... [Molding 1]
1

= Hame | Data Type | Current parameter | Meszzag
Automatichode BOOL i2.0
Manualiode EOOL :i W ERNELH S ]
I zrbd zaluiit BOOL
termp_of_product Feal "fEALE " temp_of_productl
inject_rnaterial Bool q3.0
extruzion Bool q3.3
cooling EBool gib | HELZEHHIEE
deliver_product Bool q4.1
R obat_fetching Bool i
product_OF, B ool Fobot_1.product_ok_1 ouk

B 5-12: SrEC RN OS5

16) KR BCRRMHL 2, 3 SHIE DS, RN/ SRCE SR, B 8] DLE L

17) Sy T 125

e & fetching_ 1, fetching 2, fetching 3, ZMili%4s 1-3 SRHL, Skiti%
e 7 IEAE ZE 5 6 AL TAF

e H& Product_ok 1, Product ok 2, Product_ok 3, 7»Wl##5% 1-3 SHANL T
Pt E 5



f% S|E| 8| &= o] euld| & 1<]>N2]

Molding 1
Malding
1
ferling 1/ Rabof BEhiag
Molding 2
Molding el pvechied OV oo £OK_
3

[rOCiICE K/ prockic? ok R

Mol ding_3 H—f_

Moiding
4

4

X||Graph group(1] - example_languagetS 7 Program(S)... [Fiobat_1]

4
Hame | Data Type |Eunent parameter | Meszzag
Autornatich ode BOOL i3.3
M arualtdods BOOL
Ilarhd gt BOOL
move_to_linel Bool qd.4
move_to_line Bool qd.h
move_to_line3 Boal q4.B
Product_ok_1 Bool i
Froduct_ok_2 Bool HERERHHEE in
Product_ok_3 Bool i
fetching_1 Bool kalding_1.Fobot_fetchi ot
fetching_2 Bool Molding_2.Fobat_fetching ouk
fetching_3 Bool kolding_3.Robat_fetching out

K] 5-13: SN TH: 1S4

18) £ b Options->Settings for graph groups/state graphs->Compile % & 4 1% 4= 1%
f) FC 1 DB F¢'5-.



Graph Group Settings 'Graph’ 5[

Fontz I Graphicsl Save Format - Compile |Diagnu:use|

FLC:

DB:

¥ Festucture data block

WEFS

[ Generate reference data
b emorn reserves [wardz] in data block: IE
— Only far ingtances without their own carezponding settings:
¥ Switch Any transitions once only
W Execute cypclic actions with BLO=0

[T Include preceding cyclic actions in entry cycle

Cancel Help

K] 5-14: & GRAPH 2%

19) 41k, fE£ OBl Hil§H] FC30, FF F#k
20) % graph group

oo a1~ = O = R G ™1 | ez e

Molding 1
Maiding

H 1
FEhing 1./ Robot reEh kg
Molding_2 \ Robot 1
Molding |- poocrowpeaczo s ad Aohot

o 3 _—7 |

prociic? OF 7 prockic? o3

Molding_3

Wolding ; IR A

K] 5-15: i#% graph group

21) XUili molding_1, o] AN AR B



f%| @6 8| (=8| ofc| gl 6

1 Infect makrial;
rextrag on;
E recalli; o
1k e 1_procinet;
Tkt B kg,
I prcsinct ok;
[i } - [ ]2 avimatcmee;
E I et Ok
£ Iifect marial;
; a Rostetig;] 0 W 0 o777 7 1T nfect markrial;
B 1 Bmp_1: HACE

E

§ exirazhon;
F grtraz bon;
WT [T#i1S

=

E | ke pronct]] |1 EMP_OTpmehct

- ;
% [ 1 et _prodet, [ _I_r_g:'":"

[ e ! r-:;:-:-lllg; ¥ [E & cooiy; ]

-

K] 5-16: % state graph
22) TE3E 1) Debug -> Select variable, dEFoe ORI &

Select ¥ariables i

Instances:

Folding_1
Malding_2
Malding 3

" anables/symbaol: Selected vanable/symbol

kuolding_1 . Automatictiode
Malding_1 . cooling

3|
[wlfetching_1 [DB30.0E=2.0) Moldin 1 del it
Wifetching_2 (DB30.DBX5.0) M2|d::§:1 S
wifetching_3 [DB30.DEXE.4] Malding_1 . inject_matenal
[JIMIT_SD [DB30.0E=4.5) Malding_1 . product_0OF,

[move_to_linel [g4.4] kuolding_1 . Robat_fetching

: Raobat_1 . Product_ak_1
[dmovs to lines (o) FRobat_1 . Product_aok_2

[Imove_to_line3 [g4.6) Robat_1 . Product_ak_3

WiProduct_ok_1 [DB30.DBX3. 4] Rabot 1 . fetching. 1
WIProduct_ok_2 [DB30.DBX3.5) Robol1 . etching 2
WIProduct_ck_3 [DB30.0E%3.6] obot_1 . fetening
(75T _Curalue [DE30.DEDEE] Fiobet 17 auomstichiods

15T _Ewpired [DE30.0BX4.3) =
b 4| |
B 5-17: kR REAE

23) HilJa, ARG AR R R AT %




ﬁ Table Edit Insert PLC  Wariable View Options ‘Window  Help

| Dls(E] 8] &[mle]o] x| 8] M|

é hddre=ss Hame Srmbol Dizpla Status ralue

1 I 3.0 SutomaticMode | “moldingl_auto” %DTDI_‘.M

2 Q 3.6 cooling “coolingl” BOOL

3 Q 4.1 deliwer product “deliver_productl” (BOOL

i ] 3.3 gxtrusion "extrusionl” BOOL

] Q 3.0 inject_material “inject _materiall” (BOOL

! DE30. DEX d.4 ‘Product_ok_1 BOOL

T DE30. DEX 2.0 ifetching 1 BOOL

i DE30. DEX 3.4 ‘Product_ok_1 BOOL

El DE30. DBEX 3.5 Product ok 2 BOOL

10 DE30. DEX 3.6 ‘Product_ok_3 BOOL

11 DE30. DEX 2.0 fetching_1 BOOL

12 DE30. DEX .0 ifetching_ 2 BOOL

13 DE30. DEX 6.4 fetching 3 BOOL

14 I 3.3 SutomaticMede  “robot_auto” BOOL

is| DEI0.DED & "HELE". temp_of_pr FLO...

K] 5-18: Wi e
Z, —/MAEEA S7-HiGraph FEFRBIEER T, BRTRE, ASOd6FREF1E T i abH,
VA HIERIL S7-HiGraph RAFTE. FEJN S7-HiGraph TR —ANIRERE, 2 A iip
FBF-

Tap
= Output_up, -
l € = 0OM _top: I:iom top
? put_at_toy E|R0M botiom;
."1 1]

—0

A Enable_lower;
" 1A Bulton Plus;

2 A Enable_raise,
7| A Button_Minus: 2 A Enable_lower,

A Button Plus:

Mo verment up
C| = Qutput up;
o7 [teas

Movem. down
C |= Output_down:

A Button_Plus:
AN Enable _|ower,
0

el ?| A Button_Minus: [2]A Input_at_bottam;
AM Enable_raise;

2

Al 718 Input_at_bottam;

c| = Output_down;
= OM_bottom;

K| 5-19: S7-HiGraph /3 F 11

[2 JAM Input_at_bettam:

[1H |© UsrMsgQuit,
|0 AutomaticMode;

T gREE 5 WA B E, IR IE 81— 4Bl 5498, KT S7-HiGraph MR, TH1%IE



ASCHRALR R R RE T 30 S7-HiGraph Tt
5.3. EERERR:
ORI TR H A TR S R, an b R ARG B 1 AR R AR
TR, WEIERE VIS TR SRR .
BT TR TR, AR R DL 5 S I B SR IR R . AR VR R AR
FP AT D) B MBI A PR 54T, 2 XU B
P TF AR TR P 1 B R B O AR SRR

6. & A &

6.1. 5> m 3
6.1.1. HK: S7-HiGraph RZ&EH & FERIPATIT 24 R

i@ S7T-HiGraph MRE Bl 1 & P VE AT IR T =2 AT A FER 2
ff% JLIRBITE ST-HiGraph FMHA 7.2 ST A EAIREA, XHEIRHEE— R ERMEF, Bk
L o B ER AR ST-HiGraph R A& Bl 59 % Fh sl /R AT IR «
THEEE T, BRFETERVIAIE, MRS 0 PUTENRZS 3. TEULIAE, FHIZES B
17+
e WKEI1ME, C-, C, XBhE
o EMENME |
o IRE2MHIE, C-, C, XBNE
o JJRE3HE, IE
FESLRRARIEA P R SIERATIBF AN R 12 BRI 7 BE4T 7 !

N TRFEFHEPAT I, FANERAT R ESG, #OR I MO IR N AE X SRS RT3 1ER
PRI METhRE A BN T AR FCL Sk 5E AR
0B1 Hr i fXhG:

CALL FC 31

INIT_SD:=M100.1
M A e R ER A M100.1 B FALSE 245N TURE, SERMIMGtL, FFXUS N FALSE, R3S
P 58 il — IR RE



12 3 W] g
9 L H R
B 20 1 AT

i .
L .!Tl.!;
LT MW30;
Call FC1;
L O
E T MD5O;

K 6-1:

|'j |4 INIT_SD;

L a El.“ J
E|T MW30;
call fel;

L a C_.‘ J
c—|T My 20;
call fel;

L a Cl.‘ J
1C T MW=0;
call fel;

L a Kl.‘ ll
T MW30;
call fel;

L ‘EZ:

E (T MNW30;

CALL FC1;

L a C_.‘ J
C—|T MW30;
) CALL FC1;
L 'cZ;
C|T MNW30;
CALL FC1;

L ¥z
(T MNW30;
CALL FC1;

0L 1 G BRIR I A R AR AT BN i B, REF BT S5 R I T -

| D||| 8 $l=lelol= X[ 8

| FE: T1LHE X1

"“g Addre=s IJ_J Displary fumtl Statuz wvalue

it m 50 - HEX
2| W30 | CHARACTER
g i E IE
4| 0 TCHARACTER L
- EHW' ! ?'C = s
o] w4 amuerm e |

. s o L U TH
T 6 : CHARACTER
5| 8 | CHARACTER
3| W 10 | CHARACTER
10 m_llllr 12 - - IER ......................................
1| MW 14 | CHARACTER
1z m_w_ ]_E - - IEK ......................................
13| MW 18 | CHARACTER
14 H ]_|:||:|_]_- -Bﬁuj]'_. ................................... I

Kl 6-2: PP AT R (a)



B 2: RASE g IEIE TGS T .
Do not use graph group settings, use instead (A~ FH BRI B, Tl A B Q% H)
Include preceding cyclic actions in entry cycle (7E#E N J& HHR $h4T preceding cyclic
actions)

FEFFPAT AR LT 1A

| D] 8 &[efelo]o] | [FEe

‘.'g Addre=zs LL' Display format| Statu=s wraluea
1 M 50 HEX D 1 £#00000000
2| w30 CHARACTER. N
: |
4 I 0 CHARACTER "El / EE: B
5 I 2 CHARACTER "o _— _ C-HMEEJEZ
6| M 4 CHARACTER gk 17 —%
T 6 CHARACTER. ol
8| (MW & CHARACTER T1
a | W 10 CHARACTER. X1 o
| w12 CHARACTER i R P
1l M 14 CHARACTER =] ?j%KEEE%#h
12| w16 CHARACTER Yty Tr—&
13| w18 CHARACTER oy
4] w20 CHARACTER X2
15| M 100.1- EOOL | false

K 6-3: TR AT 45 R (b)
oL 3: RSB PRIETIF %S T (S7T-HiGraph V5.3 K& LA ERRASAS 75 B2 FR b i)
Do not use graph group settings, use instead (A~ F B R4 B, Tl A B Q% H)
Execute cyclic action with RLO=0 (RLO %& N 0, 47T cyclic actions)
FEFFHAT AR W T



w| Di(E| S # (o] x| [ 8

‘:g Addre=zs LL' Display format| Status wvalue
1 M 5O HEX DWi 1 6#00000000
z M 30 CHARACTER oy
3
4 I 0 CHLRACTER "E1°
5 il 2 CHARACTER C1° .
3 m 1 CHLRACTER ol )R A T SE
7 I B CHARACTER ’Tl’/ Ja#f Z AT —Ik C
8 0] g CHARACTER “qy E, MR N Cl
3| MW 10 | CHARACTER "EZ° (UL PRy V5.3 11y
o] My 12 CHARACTER ol :ﬁjz R, AR
1| M 14 CHLRACTER -’
1zl My 16 CHARACTER R
12| My 18 CHLRACTER Vi 16#0000
14| N 100.1 BOOL [ false

Kl 6-4: FEFFHATEIR ()
6.2. 5EABKTIHEKEE

6.2.1. []&: S7-HiGraph IRZ B A X ¢ A1 F- 4k ng

)@ : S7T-HiGraph RS B A i S (R B2 3 hik g 2

fif%: ST-HiGraph MR B H A58 4 S Frlal i ik OS2 EF POINTER Hdi 258D . X TRk 454,
W, FREASCRE, MMM AT LS HFMIIE 8 &, Wi A B IhaE, e
IXUEFR A YR S TE FB 8¢ FC 71, F{E S7-HiGraph 1A MIshEFR A . Wi L+ FCL fE A .

6.2.2. [&: RTATERE Delay time
W@ N4 ik E Delay time ?

fif%: Delay time ZHREFT L S7-HiGraph V5.3 KU ERASCRE, MCHTH V4, V5, V5.2 #EA L
Theg.

6.2.3. &: S7-HiGraph REEHFHIXH ARRAY HiERAIG?

[ayay

A @: S7T-HiGraph JRZ B i HF ARRAY Hf sy ng 2
fifZ - ST-HiGraph RS HIAS I EE ARRAY HiEM, VRN AT IS H T 8 &

6.2.4. [ARE: WfT@it IN. OUT F IN-OUT ZFESLH UDT(H /- B X HiE K R)?

)@, fnfaf#E S7-HiGraph HFi@id IN. OUT A IN-OUT AR & S8l UDT(H /- [ & X BRI HY) 2
fiRZ5 Af ST-HiGraph mF AR BHERES < <UDT~ 7 R & . dn AR SC=<UDT >~ 382/ IN. OUT #1



IN-OUT A2 &, iH4&ME T 213t () 2 Rtk AT o
AR 1: {E SIMATIC Manager ™ fdidscfbse, 78 STEP 7 I H i A—/> UDT, SEHLERIEN

e "Insert > S7 block > Data type"

76 UDT HIJE TP N HA» A5 44 (14029 UDTL 43 “Testing” ) Bl 5 57 "OK" {47 .
FTFHF UDT ““Testing”~ J-7E3R i N AN 1) A8 & /a5 A,

STL/FEBD -UDT1
File Edit Imsert PLC Debug Yiew Options MWindow Help

DIl 8] Fl=la] o] el [o =l <P Oj= s

s
HEE
[ttt
[t

[
P i PR P

Motor_On BOOL FALZE

Motor_ Off EOOL FALZE

LPRAY[1..20]

JBTTE

+22.0( |Motor_Name STRING[Z254] H

+2758.0| (Exror_Message (WORD W#la#0
-TTﬂwWﬂwWWﬂwwwww-EHD_STRUCT

s =
S S,

= [rissiisiiaiainainiiininiing

= m
anAnn AR R

[lisdnsiadainsandindnniadinsad

Temp_Data

I T
i

R L L L L L ) o
B e e

K 6-5: & X UDT
SR 2. MEEER A UDT-ZREB R IR, SERRAEN

e "Insert > S7 block > Data type"

HH RN D554, Bt "Testing_Data". wWE s, X+ DB1, MFIEHFiEF "DB of
type" A1 "UDT1".

Properties - Data Blo

General - Part 1 | General - Part 2| Calls I .-'f-.ttril:uutesl

Mame and twpe: IDEH DE of tupe j UDT J

Symbolic Hame: ITesting_Datal

Symbal Comment; I

Created in Language: I ] j

K] 6-6: tR¥E UDT 4= s e



AIR 3:

HI<<UDT~~ 5 XA & . 286K, XTT INZEE< Mot 177 f1<<Temp_177 #4574 (BOOL Al

f£ Source CAFI, FTIFEIRAR)E TR AR K. AE3E O i A BIDREE R B 2R
1)

255 UDTL AR B R SR AU UL I

2% 2|8 & &3] o] enldl | ] N2| [E[E [100%

i S
J-J Pe mMmane vk P.II.EEIIQEI
- - U INIT_SD;
El--% Environment —
[ .

EI@ Interface

=43 1N

----- B AukamaticMode
B ManualMade

b
d0m QT
-2k TN_QUT
o = o 9
[+-{ZH] Blocks !
-5 Symbols
EEI---‘ Libraries . N
HIE
=f:: " ariables 4 | |
2| |Madul_1 - Test_e\SIMATIC 300[Z5CPU 315-2 DY
- |Hame |Data Type  |Comment
= Automatichode (BOOL Betriebzart Automatik
= ManualMode BiooL Betriebzart Hand
= Usrisgiui BiooL Meldungsguittierung der Formatwandler-Diagnose

= Temp_1 Biyte

DL IR Application messages A Document messages f, Instuctions 4, Cunent parameter A variables F

K 6-7: FHIASE

Pl INZEZ G, REIREER.

WIR 4.

iR A 2 B R Ik RS B (FEARBI N Modull 1). 7€ Details ik #EAr%"Current

parameter” J[) IN A8 E 20 IC UDT 4. AR5 IRA7 HEgm PR R 4.



2% 2 | & &3] o] ebldnl & L] N] [m[E [100%

1=

Eh% Environment
EI@ Interface
=-1m 5TAT
=G Modul1_t
43 IN
----- = AutamaticMode
----- B ManualMode

-2 UsrbtsqQu Modul1_1
B Mat Mo 1
LB Temp_l T 1
- ouT
-0 IN_QUT
Y ariahl
=f:: anables *l |
fll Group 1 -- Test_ehSIMATIC 30002ACPU 215-2 DPY... [Modull _1]
L
Hame |I]a‘ta Type |Current parameter |Message |Cumment
A tamatichlode BiooL Betriebzart Auta
hanualhode BiooL Betriebzart Hane
Lzrhdzgcit Bl heldungsguittier
bt 1 Boal "Testing_Data" Matar_On
Temp_1 Byte "Testing_Data" Temp_Data[1]
1l Illdl Ilhll'-. Dpplication meszages )\ Documert Meszages h [hetructions M Current parameter | Vatiahles

K 6-8: & LS5
ABR 5. MERER BT DEH R UDT 2401 IN BEFETRE. W TFEfR, £
e OIN R Mot 1" BEAT S5ERME, R EH SR TR THRIEY DBl (RS 4N
"Testing_Data" ) #(#i2k% UDT1 (554N "Testing” )2 % "Testing_Data.Motor_On"



Permanent irstructions U INIT_S D

C- i

C

Iﬁ Var - [VAT_1 -- @HiGraph_Test\SIMATIC 300(1)WPU 31... |_ Ol

K2 Table Edit Insert FLC Varisble WView Options Window Help ;|i|£
#| Dl &) %m0 | X[ 2] W
Spfes o] 65| s ' et

A& 5odress | Symbol | Displa| Status value | Modify value
LE1DBEx 00 I"Testing_Data"Mutnr_On I BOOL .true true

] 6-9: FRIFIBAT HiiLs R
6.2.5. JIEH: REESIREEZ A KITH BAR SRR LB SRR ?
L RS PR RS P 2 ) S S A e M 25 2

fisr: HAT S7-HiGraph (S FRpAi /REEEIRAFITH EAS A, A1 AR B 2 18] B AT M L B s e,
w M /AR



